VxRail TOR Switches Configuration Guide

In this post, I am going to show you how to configure VxRail TOR switches based on SmartFabcric OS10 for VxRail deployment.

Mature male engineer with short, graying hair and a neatly trimmed beard, configuring the Dell TOR switches for VxRail cluster deployment in a datacenter - UFOtechs

Properly configuring Top of Rack (TOR) switches is crucial for setting up VxRail clusters efficiently. This guide walks you through the essential steps to configure TOR switches to support a VxRail deployment.

Pre-Requisites

Before starting the configuration, ensure you have:

  • Access to the TOR switch CLI through console cable with default username "admin" and password "admin".
  • Basic understanding of networking concepts such as VLANs, IP addressing, and routing.
  • Make sure that the firmware OS10 is up to date. Check Dell SmartFabric OS10 Installation Guide.

Configuration Sscript

Use the following configuration script after replacing the green colored inputs by the actual planned inputs.

config
ip route 0.0.0.0/0 10.10.10.254
no ipv6 mld snooping enable

configure terminal
hostname TOR-1

interface mgmt1/1/1
no shutdown
no ip address dhcp
ip address 10.10.10.1/24
management route 0.0.0.0/0 10.10.10.254
ipv6 address autoconfig

interface vlan 100
description MGMT-VLAN
ip address 20.20.20.1/24

vrrp-group 11
priority 150
virtual-address 20.20.20.11
no shutdown
ipv6 mld snooping enable

interface vlan 50
description OOB
no shutdown

interface vlan 60
description vSAN
no shutdown

interface vlan 70
description vMotion
no shutdown

interface vlan 80
description VM-Network1
no shutdown

interface vlan 90
description VM-Network2
no shutdown

interface vlan 3939
description Internal_Mgmt
no shutdown
ipv6 mld snooping querier

interface ethernet1/1/1
description "Appliance1 Port1"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 3939,100,60,70,80,50,90
flowcontrol receive on
flowcontrol transmit off
spanning-tree port type edge

interface ethernet1/1/2
description "Appliance1 Port2"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 3939,100,60,70,80,50,90
flowcontrol receive on
flowcontrol transmit off
spanning-tree port type edge

interface ethernet1/1/3
description "Appliance2 Port1"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 3939,100,60,70,80,50,90
flowcontrol receive on
flowcontrol transmit off
spanning-tree port type edge

interface ethernet1/1/4
description "Appliance2 Port2"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 3939,100,60,70,80,50,90
flowcontrol receive on
flowcontrol transmit off
spanning-tree port type edge

interface ethernet1/1/5
description "Appliance3 Port1"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 3939,100,60,70,80,50,90
flowcontrol receive on
flowcontrol transmit off
spanning-tree port type edge

interface ethernet1/1/6
description "Appliance3 Port2"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 3939,100,60,70,80,50,90
flowcontrol receive on
flowcontrol transmit off
spanning-tree port type edge

interface ethernet1/1/7
description "Appliance4 Port1"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 3939,100,60,70,80,50,90
flowcontrol receive on
flowcontrol transmit off
spanning-tree port type edge

interface ethernet1/1/8
description "Appliance4 Port2"
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 3939,100,60,70,80,50,90
flowcontrol receive on
flowcontrol transmit off
spanning-tree port type edge

interface ethernet1/1/49
 description VLTi
 no shutdown
 no switchport

interface ethernet1/1/50
 description VLTi
 no shutdown
 no switchport

interface ethernet1/1/51
 description VLTi
 no shutdown
 no switchport

interface ethernet1/1/52
 description VLTi
 no shutdown
 no switchport

interface ethernet1/1/55
description UP-Link-1
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 3939,100,60,70,80,50,90
flowcontrol receive on
flowcontrol transmit off
spanning-tree port type edge

interface ethernet1/1/56
description UP-Link-2
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 3939,100,60,70,80,50,90
flowcontrol receive on
flowcontrol transmit off
spanning-tree port type edge

vlt-domain 128
backup destination 20.20.20.101
discovery-interface ethernet1/1/49-1/1/52
peer-routing

interface port-channel 11
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 3939,100,60,70,80,50,90
vlt-port-channel 11
spanning-tree disable

interface ethernet1/1/55
no shutdown
channel-group 11 mode active
no switchport

interface ethernet1/1/56
no shutdown
channel-group 11 mode active
no switchport

do write memory{codeBox}

To simplify the process of preparing this configuration script, I've developed the VxRail TOR Configuration Script Generator (VTCS-Gen). This tool automates the creation of the configuration script based on your input parameters.

You can download the VTCS-Gen Tool by clicking the button below:


Alternatively, you can Run VTCS-Gen Tool directly from PowerShell with administrative privileges using the following command:

irm https://bit.ly/VTCS-Gen | iex{codeBox}

Conclusion

Configuring TOR switches for VxRail clusters is essential for ensuring optimal performance and reliability of your hyper-converged infrastructure. By using the script or the VTCS-Gen tool, you can set up your TOR switches to support VxRail effectively, providing a robust foundation for your data center.

This setup ensures that your TOR switches are configured to handle the specific requirements of VxRail, including high availability, VLAN segregation, and optimized network traffic flow. After completing the configuration, you are now ready to proceed with the deployment of your VxRail cluster. Check VxRail Cluster Deployment.

Post a Comment

Previous Post Next Post

Contact Form